Παράξενο πρόβλημα με Vulkan και Nvidia κάρτα

Imgema

Alien RetroDatabase
Joined
4 Ιουν 2009
Μηνύματα
5.007
Αντιδράσεις
956
Μια φορά και έναν καιρό (πριν από λίγες μέρες) έκανα update τους drivers για την GTX 960 και όλα ήταν μια χαρά. Κάποιες Vulkan εφαρμογές που είχα (ParaLLEl και Vulkan Fish benchmark) δούλευαν τέλεια.

Ομως ξαφνικά (σήμερα) και χωρίς να κάνω καμία αλλαγή στο σύστημα, αποφάσισαν οι εφαρμογές αυτές να μην δουλεύουν πετώντας ένα error message ότι λείπει το "vulkan-1.dll" από το σύστημά μου. Και όντως δεν ήταν πουθενά. Ούτε στο system 32, ούτε στο virus vault. Για κάποιο λόγο εξαφανίστηκε από μόνο του. Αυτό είναι το πρώτο περίεργο της ιστορίας.

Ετσι λοιπόν κι εγώ βγήκα στο δάσος (στο internet) για να βρω μία λύση. Διάβασα ότι το να κάνεις re-install τους drivers μπορεί να μην δουλέψει και ότι η καλύτερη λύση είναι να κατεβάσεις το dll αυτό μόνο του και να το βάλεις στο system 32.

Ετσι λοιπόν και έκανα. Κατέβασα το dll, το έβαλα στο system 32 και δοκίμασα να δω αν οι εφαρμογές λειτουργούν. Ομως εδώ ξεκινάει το δεύτερο περίεργο. Οι μισές εφαρμογές Vulkan δουλεύουν και οι άλλες μισές πάλι πετάνε το ίδιο error messege. Για παράδειγμα, το ParaLLEl αλλά και ένα vulkan demo με ελικόπτερα δουλεύουν. Ομως το Fish benchmark συνεχίζει να λέει ότι λείπει το dll, παρόλο που οι άλλες εφαρμογές το βλέπουν (να υπενθυμίσω ότι μέχρι χτες δούλευαν όλα).

Υπάρχει καμιά ψυχή εδώ μέσα να μου εξηγήσει γιατί γίνονται όλα αυτά? Πως εξαφανίστηκε το original dll και γιατί το καινούριο το βλέπουν μονο οι μισές εφαρμογές και οι άλλες μισές όχι?
 

arpacolla

RetroActive
Joined
4 Ιουν 2009
Μηνύματα
465
Αντιδράσεις
164
Imgema είπε:
Υπάρχει καμιά ψυχή εδώ μέσα να μου εξηγήσει γιατί γίνονται όλα αυτά? Πως εξαφανίστηκε το original dll και γιατί το καινούριο το βλέπουν μονο οι μισές εφαρμογές και οι άλλες μισές όχι?
Ίσως οι μισές ψάχνουν την 32bit έκδοση της lib και οι άλλες μισές την 64bit. Δεν μπορώ να σκεφτώ κάποιον άλλο λόγο.

Addendum: λάθος, μπορώ να σκεφτώ και άλλο λόγο. Δεν τη βρίσκουν στο path που τη ψάχνουν.
 
Τελευταία επεξεργασία από έναν συντονιστή:

Imgema

Alien RetroDatabase
Joined
4 Ιουν 2009
Μηνύματα
5.007
Αντιδράσεις
956
Ευχαριστώ για την απάντηση. Θα κοιτάξω να δω μήπως μπορέσω να βρω και τις δύο εκδόσεις.

Για το path δεν ξέρω αλλά έχω την εντύπωση πως δεν μπαίνει αλλού το dll εκτός από τον φάκελο system 32. Οπότε το πρώτο που είπες πρέπει να είναι.

Edit: Τελικά δεν έβγαλα άκρη και είπα να δοκιμάσω να ξανακάνω install τους Drivers. Ευτυχώς έτσι λύθηκε το πρόβλημα. Παρατήρησα ότι δεν ήταν μόνο ένα αρχείο αλλά 4 που έλειπαν. Δεν ξέρω γιατί εξαφανίστηκαν πριν αλλά τώρα τα έχω κάνει backup.
 
Τελευταία επεξεργασία από έναν συντονιστή:
Μπλουζα