Πρόβλημα με φόρτωση binary file στην memory ή συντακτικό λάθος?

gremlinakos

RetroActive
Joined
28 Οκτ 2007
Μηνύματα
485
Αντιδράσεις
28
Καλησπέρα παίδια!

Θα ήθελα κάποιος αν μπορεί να μου λύσει ένα περίεργο πρόβλημα γιατί πραγματικά χθες κόντεψα να τρελαθώ.

Έχω κατεβασει ενα zip με εργαλεία για amstrad cross development και συγκεριμένα την ccz80++ language.

Μέσα στο πακέτο υπάρχει και ένα image disk με κάποια examples bin files. Μάλιστα έχει και ένα readme που σου λέει με ποιόν τρόπο να τα φορτώσεις. Δηλαδή τον γνωστό και κλασσικό τρόπο:

MEMORY &3FFF

LOAD "example1.bin",&4000

CALL &4000

Ε λοιπόν είτε το βάλω σε listing, είτε το εκτελέσω εντολή προς εντολή, μου χτυπάει syntax error στο LOAD.

Αν δεν βάλω το κομμάτι που δηλώνω την μνήμη που θα πάει, δηλαδη ',$4000', επιστρέφει Ok χωρίς syntax error.

Είναι να τρελαίνεται κανείς, γιατί σε άλλα image discs με άρχεια bin που φόρτωσα στην memory με τον ίδιο τρόπο, δεν μου επέστρεψε κανένα συντακτικό λάθος. Μπορεί κάποιος γνώστης να βοηθήσει να βρω λύση? Δεν έχει λογική πραγματκά. Δε μπορώ να καταλάβω τι λάθος κάνω. Τις δοκιμές τις έκανα στον winApe και στον droid-cpc και σε όλα τα αρχεία της δισκέτας. Ευχαριστώ!
 

fgbrain

RetroActive
Joined
27 Οκτ 2006
Μηνύματα
315
Αντιδράσεις
20
Το μονο που μπορω να σκεφτω ειναι οτι υπαρχει λαθος στο αρχειο...

Μαλλον το image το συγκεκριμενο
 

gremlinakos

RetroActive
Joined
28 Οκτ 2007
Μηνύματα
485
Αντιδράσεις
28
χμμμ λες ε? Πολύ πιθανό, αν και το error που επιστρέφει, δεν κολάει πουθενά για πουθενά..
 
Μπλουζα