Πρόβλημα με ZX Spectrum

  • Έναρξη μίζας -
  • Ημερομηνία έναρξης

Guest
Καλησπέρα σας,

θα ήθελα τα φώτα σας παρακαλώ καθώς αντιμετωπίζω ένα πρόβλημα με τον "καινούργιο" μου ZX Spectrum.

Συγκεκριμένα τον πήρα από μία αγγελία για να ξεκινήσω να ασχολούμαι με πολλή όρεξη, όντας παντελώς αρχάριος στον χώρο, αλλά δυστυχώς πλέον θέλω να του κάνω κακό, καθώς την τρίτη μόλις φορά που τον άνοιξα ξεκίνησε να πατάει μόνος του τυχαία πλήκτρα. Ακουγόταν και ο ήχος κανονικά, σαν να τα πατούσα εγώ. Τον έκλεισα και τον άνοιξα περί τις 20-30 φορές από τότε και η συμπεριφορά είναι η ίδια, άλλες φορές πατάει πολύ συχνά και άλλες αραιά και που.

Τον άφησα κάποιες φορές ώρες ολόκληρες ανοιχτό να σκεφτεί τι θέλει να μοιραστεί μαζί μου και να μου γράψει μία πρόταση να βγάζει νόημα για να καταλάβω ποιο είναι το πρόβλημά του και να το συζητήσω μαζί του για να το λύσουμε, αλλά το μόνο που κατάφερνε ήταν να κολλήσει τελείως μετά από κάποια ώρα λειτουργίας.

Στην αρχή με άφηνε να γράφω κι εγώ παράλληλα κάποιες φορές, κάποιες άλλες κολλούσε για κανένα 10λεπτο και με άφηνε μετά να γράψω για λίγη ώρα πριν ξανακολλήσει.

Ακολουθώντας την συμβουλή όλων όσων ρώτησα, αγόρασα μία καινούργια μεμβράνη από ebay και αντικατέστησα την παλιά καθαρίζοντας παράλληλα όσο μπορούσα, με ευλάβεια το εσωτερικό. Το δυστυχές είναι πως ενώ φαίνεται να έχει εφαρμόσει τέλεια, πλέον δεν μπορώ να γράψω καθόλου, αν και από μόνο του γράφει πολύ πιο αραιά από πριν. Εκείνο που με απογοήτευσε τελείως όμως, είναι πως παρατήρησα πως δεν έχει καμία ανάγκη το πληκτρολόγιο για να αρχίσει να γράφει. Ανάβοντάς το χωρίς να συνδέσω καθόλου την μεμβράνη πάνω του, άρχισε και πάλι να γράφει τα δικά του, οπότε σίγουρα δεν είναι η μεμβράνη το πρόβλημα.

Υπάρχει σωτηρία; Το έχει αντιμετωπίσει κάποιος αυτό και αν ναι, έχει βρει λύση;

Σας ευχαριστώ πολύ εκ των προτέρων.
 

Muttley Black

Retro Member
Joined
21 Φεβ 2015
Μηνύματα
153
Αντιδράσεις
97
Αν και παλιά δημοσίευση, να αναφέρω εδώ για άλλους που μπορεί να έχουν στο μέλλον το ίδιο πρόβλημα πως την ευθύνη για την σωστή λειτουργία το πληκτρολογίου στον ZX Spectrum έχει η ULA. Υπάρχει και η πιθανότητα βλάβης στην CPU.

Αυτο που θα δοκίμαζα εγώ πρώτα είναι αφαιρέσω με προσοχή ULA & CPU από την πλακέτα (αν είναι σε socket), να έκανα έναν καλό καθαρισμό στις επαφές με isopropyl alcohol και να ξανά τοποθετούσα στην θέση τους τα IC.
 
Μπλουζα