ZX Spectrum πρόβλημα

cauldron

RetroActive
Joined
9 Αύγ 2007
Μηνύματα
419
Αντιδράσεις
11
Αγαπητοί sinclairάδες του φόρουμ, φαίνεται ότι θα γίνω κι εγώ ένας από εσάς... Πρόσφατα αγόρασα (και) έναν ZX Spectrum issue 3. Ζητάω βοήθεια, δείτε τις παρακάτω φωτογραφίες και πείτε μου αν βγάζετε συμπέρασμα. Κάθε φορά που μπαίνει στο ρεύμα εμφανίζει μία απο τις παρακάτω εικόνες: (Τα τετραγωνάκια αναβοσβήνουν, εκτός από την πρώτη φωτό που παραμένουν αμετάβλητα.) Υποπτεύομαι ότι θα φταίει η CPU ή ULA. Υπάρχει κάποιος τρόπος να επιβεβαιωθεί η αιτία?

attachment.php


attachment.php


attachment.php


attachment.php


attachment.php


attachment.php
 

angel_grig

KAT Resurrector
Joined
11 Οκτ 2008
Μηνύματα
3.161
Αντιδράσεις
376
Eντυπωση μου κανει ο χαλκος στα traces της motherboard.Φαινεται σαν εχει φουσκωσει και να εχει αποκολληθει απο την πλακετα..για κανε ενα continuity test με ενα πολυμετρο να δεις τι γινεται πριν να αλλαξεις τον Ζ80..αληθεια ,πριν δουλευε ή σου ηρθε ετσι?
 

cauldron

RetroActive
Joined
9 Αύγ 2007
Μηνύματα
419
Αντιδράσεις
11
Δεν ταιριάζει με κανένα Wally. Ίσως με αυτό Spectrum 48K The screen showed a lot of colour pixel (there weren't anyone flash pixel). Yes Fault Z-80 . Αλλά εμένα κάθε φορά βγάζει και διαφορετικό Pattern!

@Angel grig Ο χαλκός φαίνεται φουσκωμένος, αλλά στην αφή είναι σκληρός, δεν έχει αποκολληθεί πουθενά. Βέβαια θα τσεκάρω αγωγιμότητα. ΚΑτά τα άλλα η πλακέτα είναι εκτελώς απείραχτη και ίσως να ξεβιδώθηκε πρώτη φορά. Έτσι ήρθε, το αγόρασα non working για να το διορθώσω ;)
 
Τελευταία επεξεργασία από έναν συντονιστή:

sonic2000gr

RetroWannaBe
Joined
6 Δεκ 2009
Μηνύματα
67
Αντιδράσεις
6
cauldron είπε:
@Angel grig Ο χαλκός φαίνεται φουσκωμένος, αλλά στην αφή είναι σκληρός, δεν έχει αποκολληθεί πουθενά.
Αν βοηθάει κάπου, και στο δικό μου TI-99 θυμάμαι ότι ήταν έτσι ο χαλκός στις μεγάλες γραμμές (γείωση) από τότε που το αγόρασα (1984)! Μάλλον έχει να κάνει με τον τρόπο κατασκευής της εποχής και δεν δημιουργεί πρόβλημα. Και σε εμένα είναι κανονικά σκληρός και κολλημένος.
 

angel_grig

KAT Resurrector
Joined
11 Οκτ 2008
Μηνύματα
3.161
Αντιδράσεις
376
Αν παντως ο χαλκος ειναi ΟΚ μπορεις να τσεκαρεις τα chip μνημης με μια παλια τεχνικη που ονομαζεται piggy back.Βαζεις πανω στο chip μνημης που θες να ελεγξεις ενα αλλο που ξερεις οτι λειτουργει και βλεπεις αν λειτουργει ο υπολογιστης..αν οχι προχωρας στο επομενο μεχρι να βρεις αυτο που φταιει..μερικες φορες χρειαζεται να σηκωσεις καποιο ποδαρακι απο το chip που χρησιμοποιεις για τον ελεγχο ενα παραδειγμα δες εδω:http://www.classic-computers.org.nz/blog/2010-09-28-2nd-sys80-ram-fix.htm.Πιστευω οτι αξιζει να το δοκιμασεις πριν πας σε αλλαγη Ζ80 πχ ή ULA
 

cauldron

RetroActive
Joined
9 Αύγ 2007
Μηνύματα
419
Αντιδράσεις
11
angel_grig είπε:
URL]http://www.classic-computers.org.nz/blog/2010-09-28-2nd-sys80-ram-fix.htm[/url].Πιστευω οτι αξιζει να το δοκιμασεις πριν πας σε αλλαγη Ζ80 πχ ή ULA
Φοβερή τεχνική :D . Λες να βρω εύκολα τσιπάκι και να είναι φτηνότερο από τη CPU? Μια γρήγορη ματιά στους Ζ80 γύρω τα 7-10 $. ΄Εστειλα μήνυμα και στον τύπο από το site που πρότεινε ο Wally. Να δούμε. Πάντως η λογική μου λέει 1.CPU και 2.ROM
 

angel_grig

KAT Resurrector
Joined
11 Οκτ 2008
Μηνύματα
3.161
Αντιδράσεις
376
cauldron είπε:
Να δούμε. Πάντως η λογική μου λέει 1.CPU και 2.ROM
Aυτο φαινεται οτι μαλλον ειναι ,απλα δεν χανεις τιποτα να δοκιμασεις και την memory.Το spectrum χρησιμοποιει τα 4116 ram chips(και τα 4532 για την upper memory) που ειναι φτηνα και υπαρχουν στο ebay.Nα δουμε τι θα μας πει και ο τυπος απο το site..
 
Τελευταία επεξεργασία από έναν συντονιστή:

cauldron

RetroActive
Joined
9 Αύγ 2007
Μηνύματα
419
Αντιδράσεις
11
Ένα update: Μέχρις στιγμής έχει βρεθεί προβληματικός ο Z80 και αντικαταστάθηκε. Το πρόβλημα παραμένει και κατά πάσα πιθανότητα εμπλέκεται και η lower RAM. Έχουν παραγγελθεί τσιπάκια 4116 για αντικατάσταση.
 

cauldron

RetroActive
Joined
9 Αύγ 2007
Μηνύματα
419
Αντιδράσεις
11
Αλλάχθηκε όλη η Lower RAM (8 τσιπάκια 4116 σε sockets). Αλλάχθηκαν όλοι οι πυκνωτές και 2 τρανζίστορ (μόνο για να είμαι σίγουρος ότι δεν φταίνε αυτά). Οι τάσεις παντού είναι ΟΚ. Έγινε απομόνωση της upper RAM, Μήπως οφείλεται εκεί, αλλά δυστυχώς το πρόβλημα παραμένει

Επειδή δεν έχω πολλές επιλογές,

ΖΗΤΑΩ ΕΝΑΝ ΕΘΕΛΟΝΤΗ ΝΑ ΤΟΥ ΣΤΕΙΛΩ ΤΗΝ ULA ΝΑ ΤΗ ΔΟΚΙΜΑΣΕΙ ΣΤΟΝ SPECTRUM TOY.

Θυμίζω ότι στους Spectrum 48K η ULA ειναι ένα τσιπάκι κουμπωμένο σε socket, οπότε η αφαίρεση και επανατοποθέτηση είναι σχετικά εύκολη διαδικασία.

Θα το εκτιμίσω πολύ αν με βοηθήσει κάποιος γιατί έχω τραβήξει ζόρι για να διορθώσω αυτό το μηχάνημα!!
 

Wally

Retired Admin
Joined
19 Ιαν 2006
Μηνύματα
25.490
Αντιδράσεις
3.267
Πηγαινε-ελα, στατικα...μεγαλυτερη ζημια θα κανεις.

Τσιμπα μια ULA (γυρω στα 10 ευρο την βρισκεις) οσο υπαρχει. Σε λιγα χρονια, αν δεν βγει καποιο replacement, θεωρω οτι θα υπαρχει ελλειψη.

Ειχα ψωνισει δυο πριν κανα χρονο και δυστυχως μου "χρειαστηκαν"...
 

nkarytia

RetroAdept
Joined
26 Μάρ 2007
Μηνύματα
932
Αντιδράσεις
7
Ψάξε αν μπορείς να βρείς κανένα Ferranti ULA Chip. Είναι σχετικά φρέσκο replacement του κλασσικού ULA των ZX.
 

vp74

Retro Member
Joined
20 Ιουλ 2009
Μηνύματα
132
Αντιδράσεις
2
Κάνε μια μετρησούλα με πολύμετρο να δεις την vcc στο ULA chip (pin40). Eίναι 5Volts;

Πριν από οποιαδήποτε αντικατάσταση καλό θα ήταν να κάνεις μετρήσεις, αλλιώς μπορεί λόγω εσφαλμένης τάσης να καταστρέφεις και τα καινούργια

εξαρτηματάκια σου και να μένεις συνέχεια με το ίδιο πρόβλημα. Ελπίζω να το φτιάξεις γρήγορα.

http://homepage.ntlworld.com/deborah.clayton1/ULA/ula.html

EDIT: το τροφοδοτικό το άνοιξες να δεις τους πυκvωτές; Δεν γνωρίζω αν το πήρες μαζί με τροφοδοτικό

αλλά αν ναι, καλό θα ήταν να αρχίσεις από εκεί...

http://homepage.ntlworld.com/deborah.clayton1/ULA/ula.html
 
Τελευταία επεξεργασία από έναν συντονιστή:

Maddog

Immense Cult RetroFigure
Joined
10 Νοέ 2006
Μηνύματα
4.887
Αντιδράσεις
78
@vp74: το link που δίνεις είναι για ULA του ZX81, όχι του Spectrum.
 

cauldron

RetroActive
Joined
9 Αύγ 2007
Μηνύματα
419
Αντιδράσεις
11
Thanks για τη συμβουλή vp74. Προς το παρόν έχω δώσει τη ULA σε φίλο να τη δοκιμάσει και βλέπουμε... Το λινκ σου άκρως ενδια΄φερον! Αλλά είναι για την άλλη ULA και άντε να τα χωρέσεις όλα αυτά μέσα :)
 

vp74

Retro Member
Joined
20 Ιουλ 2009
Μηνύματα
132
Αντιδράσεις
2
maddog/cauldron

Δεν ασχολούμαι πολύ με spectrum γι'αυτό και το λάθος, αλλά τα pins για την τάση κάπου θα τα βρείτε για την μέτρηση :p Το θεματάκι είναι να δουλεψει πάλι ένα retro μηχάνημα. Απλά είδα την φωτό και η πλακέτα είναι "καθαρή" από το κάτω μέρος (τα φουσκώματα τα έχω δει και σε amstrad αλλά εκεί έφταιγε ταλαντωτής) οπότε μην τα πειράξεις καθόλου. Ελπίζω να βγάλεις άκρη. ;)

http://www.allpinouts.org/index.php/ZX_Spectrum_ULA

ayto prepei na einai to sosto.
 
Τελευταία επεξεργασία από έναν συντονιστή:

Muttley Black

Retro Member
Joined
21 Φεβ 2015
Μηνύματα
174
Αντιδράσεις
147
Eντυπωση μου κανει ο χαλκος στα traces της motherboard.Φαινεται σαν εχει φουσκωσει και να εχει αποκολληθει απο την πλακετα..για κανε ενα continuity test με ενα πολυμετρο να δεις τι γινεται πριν να αλλαξεις τον Ζ80..αληθεια ,πριν δουλευε ή σου ηρθε ετσι?

Είναι σύνηθες φαινόμενο σε παλιές πλακέτες αυτό. Συγκεκριμένα τα pcb's των spectrum ήταν "wave soldered". Ήταν εκείνη την εποχή ένας οικονομικός τρόπος συγκόλλησης, αλλά αρκετά αποτελεσματικός.

Η μια θεωρία είναι η εξής:

Until the mid-90s, boards often went through an HASL, or "hot air solder leveling" process that put solder on the traces before the solder mask (a protective layer over the board) was applied. This initial solder over the PCB's copper traces helped avoid corrosion and, when near a point where a component would later be soldered, would help wetting so that the component could be more reliably connected to the PCB trace.

Excess solder on the traces would be removed before the mask was applied, but usually not completely on large traces. So, after being masked, when the board was wave soldered to attach the electronic components, the original HASL solder, now underneath the solder mask, would melt again and reform unevenly under the mask during cooling.


******
Η άλλη θεωρία ισχυρίζεται πως με τα χρόνια παρουσιάζεται αυτό το φαινόμενο που είναι στην ουσία η χαλάρωση του υλικού συγκόλλησης (solder) από την πλακέτα.

Προσωπικά υποστηρίζω την πρώτη εκδοχή, χωρίς όμως να το έχω διαπιστώσει. Ίσως να κάνω ένα τεστ κάποια στιγμή σε ένα από τα board's που έχω.


"Wave soldered" είναι αρκετές πλακέτες από παλιούς υπολογιστές, όπως και ο Apple 1 για παράδειγμα.





 
Τελευταία επεξεργασία:

Muttley Black

Retro Member
Joined
21 Φεβ 2015
Μηνύματα
174
Αντιδράσεις
147
Οι παρακάτω φωτογραφίες είναι τραβηγμένες από το βιβλίο "Spectrum Hardware Manual" του 1983. Είναι εμφανές στην φωτογραφία πως οι κολλήσεις κάτω από την μάσκα έχουν κυματισμό από κατασκευής τους. Άρα δεν είναι αποτέλεσμα χρόνων. Πράγμα που συμφωνεί με την πρώτη θεωρία του παραπάνω ποστ.

073-F36-D1-B30-F-4384-9-B54-E1-F2-EEEBA349.jpg

118-A2093-DD90-4139-BF2-D-0576-EE14581-E.jpg

 
Τελευταία επεξεργασία:
Μπλουζα